Vertex Music not joining VC & Music not playing

Incident Report for Vertex Music

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 03:58 UTC

Update

The Music Play & VC issue has been fixed. We are now aware that the music select options are not working. You can still play music as normal tho. We are looking into it
Posted Nov 21, 2025 - 01:58 UTC

Investigating

We are currently investigating this issue.
Posted Nov 21, 2025 - 01:50 UTC
This incident affected: Connect to a Voice Channel and Play Queue.